Tag Archive for patch procedures

The command line IS your friend: SP hotfix crisis averted

I’ve always been somewhat nervous about using the command line for doing things. But today has turned me into a convert.

I had to install a particular hotfix in order to remedy an issue we were having with alerts.  I did my due diligence by documenting my procedures, making sure to fully research EVERYTHING. I tried the hotfix in DEV and everything looked good to go. I followed Microsoft’s guide TO THE LETTER (link). Last thing to accomplish was to run PSConfig. I figured why tempt fate by doing it in the command line and just do it in the GUI.

I let the Wizard do it’s thing with each server, checked Central Admin (CA) to make sure everything was good, and then figured I was done. 25 minutes tops. I opened a fresh browser and navigated to the site. NOTHING. [enable freak out mode]

I did EVERYTHING I was supposed to do. I started to panic. Would I really need to roll back? CA told me everything was running correctly. I restarted IIS. Contemplated rebooting. I had no idea what to do.

Then, on a hunch, I figured why not try it in the command line. There are lot’s of times I’ve tried to do things in CA, only to find PowerShell or STSADM is the only way to ensure it gets accomplished. So I went to Google and did a little searching and I came up with the following:

  1. Open up a command terminal (Run > cmd > Hit enter)
  2. Change Directory to the BIN folder in the 14 hive (cd C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions14BIN > Hit Enter)
  3. And type in the following command:

    PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures

Once completed I hit the site again and we’re back. Whew.

Let this be a learning lesson. If you have the choice to do it in the command line vs. GUI, always pick the command line. Will I follow this advice every time? Probably not, but I’m a glutton for punishment.